CCSPI bug fixes.
[goodfet] / firmware / lib /
2012-09-24 travisutkFixed critical Apimote bug, which prevented the firmwar...
2012-08-15 travisutkUrgent fix for broken GoodFET31 support, result of...
2012-07-31 travisutkFixed broken LED definitions that were inserted during...
2012-07-24 rmspeersMoved board definition from apimote to apimote1 for...
2012-07-24 travisutkHello world on the Apimote!
2012-05-07 travisutkForgot to explicitly init silent=0.
2012-05-07 travisutkRemoved test transmit that was confusing client.
2012-05-07 travisutkBaud rate isn't quite right, but we're close to a conne...
2012-05-07 travisutkThe STM32 UART is finally running.
2012-05-07 travisutkSome son of a bitch put a capacitor on PA9, so USART1...
2012-05-07 travisutkStruggling with STM32 USART.
2012-05-06 travisutkAdded main clock initialization to STM32.
2012-05-06 travisutkGoodFET is booting on STM32.
2012-05-06 travisutkSTM407 port has working IVT.
2012-05-06 travisutkCloser to STM32 port.
2012-05-06 travisutkGetting closer to working Cortex M3 targets.
2012-05-05 travisutkEmpty files for STM32F407 support.
2012-03-30 travisutkRemoved old configs.
2012-02-12 travisutkio.h is deprecated, so now msp430.h is included instead.
2012-01-19 travisutkFixed synching bug which was introduced by dropping...
2012-01-17 dragornUpdate to add support for MSP430-GCC 4.6 which moved...
2011-12-23 travisutkMore fixed for TelosB and telosbbt.
2011-11-16 travisutkMore code cleanup. Broke support for the Launchpad.
2011-11-09 thequuxAdded support for uniarch mspgcc4
2011-10-18 donb127initial merge of donbfet code, sans changes to monitor...
2011-08-30 travisutkSupport for STATICDCO timing calibrations.
2011-07-20 travisutkTI Launchpad patch from Peter Lorenzen, edited to ease...
2011-04-17 travisutkArduino port is working, but only at 9600 baud.
2011-04-17 travisutkValues are better.
2011-04-17 travisutkAVR baud rates are good, but the values are hackish.
2011-04-17 travisutkAVR UARTs; not quite ready.
2011-04-17 travisutkFixed MSP430 issue w/ AVR code.
2011-04-17 travisutkArduino port is blinking.
2011-04-17 travisutkMore work toward an AVR port.
2011-04-17 travisutkPreparing for an AVR port of at least the monitor.
2011-02-12 travisutkFixed force of msp430x2618 in Makefile.
2011-02-10 travisutkAligned dco_calib.
2010-06-25 scottlivingstonTiming functions delay_ms, delay_us and delay_ticks...
2010-06-15 travisutkCloser to harmonizing different platforms.
2010-06-14 travisutkProper config.h
2010-06-14 travisutkRemoved many references to P1OUT.
2010-06-14 travisutkTelosB platform target.
2010-06-05 travisutkMore DCO calibrations, working on MSP430 testing framework.
2010-05-24 travisutkClear P2SEL to disable XIN on MSP430F2274.
2010-05-15 travisutkFixing MSP430 JTAG.
2010-05-15 travisutkProper indentation.
2010-05-12 travisutkDCO table, wider support.
2010-05-09 travisutkProper self-calibration of the DCO.
2010-05-09 travisutkBetter timing patch, resets until solid connection...
2010-05-08 travisutkFixed the P8SEL bug in msp430x2618.c, as the port doesn...
2010-04-30 bushingone-line change to make all GPIOs usable on the 80...
2010-04-12 dodge-thisUpdates to ARM7TDMI JTAG app and optimizations for...
2010-04-08 scottlivingstonFirst addition of dsPIC33F/PIC24H chip family programmer!
2010-03-18 travisutkConstruction menu item>
2010-01-25 travisutkRedefinable CALCB1_16MHZ.
2010-01-22 travisutkNew DCOCTL value. Seems to be closer to the mean.
2010-01-02 travisutkSome bits of Spy-Bi-Wire support, thanks to Mark Rages...
2009-11-11 travisutkClearing DCO per Andre@TI's advice.
2009-11-04 travisutkSPI stuff, cleaned whitespace.
2009-11-02 travisutkCleaned up LED stuff on 2xx msp430_init_dco().
2009-10-11 travisutkEarly support for 2254 on the GoodFET30.
2009-10-07 travisutkAVR client connecting and reading ID correctly!
2009-10-05 travisutkRetooled plugin interface with weak linking.
2009-10-05 travisutkDropped ugly 'blocks' kludge for a 16-bit length field.
2009-10-05 travisutkMoved header transmission to txhead, about to switch...
2009-10-03 travisutkSilence support and beginnings of proper buffer management.
2009-09-29 travisutkAtmel JEDEC info for SPI Flash.
2009-09-20 travisutkDoxygen stuff.
2009-09-20 travisutkRearranging firmware for use with Doxygen.
2009-09-19 travisutkSupport for debugging strings, closer to a clean MSP430...
2009-09-04 travisutkMSP430X2 client connects but reads garbage from ram.
2009-09-04 travisutkJTAG430X2 works at 16MHz, not at 3MHz.
2009-09-01 travisutk2274 #ifndef screwed things up.
2009-08-28 travisutkmsp430_init_dco on 2xx devices now knows defaults for...
2009-08-27 travisutkNearing support for the MSP430F2618 in lieu of the...
2009-08-26 travisutkTrying to get 2618 going.
2009-08-23 travisutkURGENT fix to 1612 clocking.
2009-08-23 travisutkAdding preliminary support for the MSP430F2618, build...
2009-08-22 travisutkREADME files. Don't ignore them.
2009-08-08 travisutkBeginning support for the second UART.
2009-07-16 travisutkChipcon client improvements.
2009-06-22 travisutkNow compiling with -Wall, error free.
2009-06-22 travisutkAdded support for transmitting a string.
2009-06-21 travisutkReclocked to 3.6834 MHz, exactly twice a standard PC...
2009-06-20 travisutkThe GoodFET can program an MSP430's flash memory!
2009-06-18 travisutkMSP430 JTAG works.
2009-06-03 travisutkSPI application transfers correctly; need only !SScommand.
2009-06-03 travisutkFirmware coming together.
2009-06-02 travisutkEcho test is working.
2009-06-02 travisutkEcho works.