BUGFIX: l3_init can fail on desfire ev3 and produce SIGSEGV
[librfid] / librfid.spec
1 Name:           librfid
2 Version:        0.1.0 
3 Release:        1%{?dist}
4 Summary:        The librfid is a Free Software RFID library
5
6 Group:          System Environment/Libraries
7 License:        GPL
8 URL:            http://www.openmrtd.org/projects/librfid/
9 Source0:        http://www.openmrtd.org/projects/librfid/files/%{name}-%{version}.tar.bz2
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12 BuildRequires:  libusb-devel
13
14
15 %description
16 librfid is a Free Software RFID library. It implements the PCD (reader) 
17 side protocol stack of ISO 14443 A, ISO 14443 B, ISO 15693, 
18 Mifare Ultralight and Mifare Classic. Support for iCODE and 
19 other 13.56MHz based transponders is planned.
20
21
22 %package        devel
23 Summary:        Development files for %{name}
24 Group:          Development/Libraries
25 Requires:       %{name} = %{version}-%{release}
26
27 %description    devel
28 The %{name}-devel package contains libraries and header files for
29 developing applications that use %{name}.
30
31
32 %prep
33 %setup -q
34
35
36 %build
37 %configure --disable-static
38 make %{?_smp_mflags}
39
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 make install DESTDIR=$RPM_BUILD_ROOT
44 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
45
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50
51 %post -p /sbin/ldconfig
52
53 %postun -p /sbin/ldconfig
54
55
56 %files
57 %defattr(-,root,root,-)
58 %doc COPYING README TODO
59 %{_libdir}/*.so.*
60 %{_bindir}/librfid-tool
61 %{_bindir}/mifare-tool
62 %{_bindir}/send_script
63
64 %files devel
65 %defattr(-,root,root,-)
66 %doc COPYING README TODO
67 %{_includedir}/*
68 %{_libdir}/*.so
69
70
71 %changelog
72 * Sat Dec 30 2006 Kushal Das <kushal@openpcd.org> 0.1.0-1
73 - Initial release