d417739063051899cfeec0fce7ff9d281d91dc80
[bcm963xx.git] / userapps / opensource / sshd / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 #
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets  by Bill Allombert 2001
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 # This has to be exported to make some magic below work.
12 export DH_OPTIONS
13
14 # These are used for cross-compiling and for saving the configure script
15 # from having to guess our platform (since we know it already)
16 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
17 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
18
19
20 CFLAGS = -Wall -g
21
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23         CFLAGS += -O0
24 else
25         CFLAGS += -O2
26 endif
27 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
28         INSTALL_PROGRAM += -s
29 endif
30
31 config.status: configure
32         dh_testdir
33         # Add here commands to configure the package.
34         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
35
36
37 #Architecture 
38 build: build-arch #build-indep
39
40 build-arch: build-arch-stamp
41 build-arch-stamp:  config.status
42         
43         # Add here commands to compile the arch part of the package.
44         $(MAKE) CC=gcc LD=gcc
45
46 build-indep: build-indep-stamp
47 build-indep-stamp:  config.status
48         
49         # Add here commands to compile the indep part of the package.
50         #$(MAKE) doc
51
52 clean:
53         dh_testdir
54         dh_testroot
55         rm -f build-arch-stamp build-indep-stamp config-stamp
56
57         # Add here commands to clean up after the build process.
58         -$(MAKE) clean
59 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
60         cp -f /usr/share/misc/config.sub config.sub
61 endif
62 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
63         cp -f /usr/share/misc/config.guess config.guess
64 endif
65
66         
67         dh_clean
68
69 install: install-indep install-arch
70 install-indep:
71         dh_testdir
72         dh_testroot
73         dh_clean -k -i
74         dh_installdirs -i
75         
76         # Add here commands to install the indep part of the package into
77         # debian/<package>-doc.
78         #INSTALLDOC#
79         
80         dh_install -i
81
82 install-arch:
83         dh_testdir
84         dh_testroot
85         dh_clean -k -a
86         dh_installdirs -a
87         dh_installdirs /etc/dropbear
88
89         # Add here commands to install the arch part of the package into 
90         # debian/tmp.
91         $(MAKE) install prefix=$(CURDIR)/debian/dropbear/usr
92
93         dh_install -a
94 # Must not depend on anything. This is to be called by
95 # binary-arch/binary-multi
96 # in another 'make' thread.
97 binary-common:
98         cat $(CURDIR)/debian/copyright.in $(CURDIR)/LICENSE > $(CURDIR)/debian/copyright
99         dh_testdir
100         dh_testroot
101         dh_installchangelogs CHANGES
102         dh_installdocs
103         dh_installexamples
104 #       dh_installmenu
105 #       dh_installdebconf       
106 #       dh_installlogrotate     
107 #       dh_installemacsen
108 #       dh_installpam
109 #       dh_installmime
110         dh_installinit
111 #       dh_installcron
112 #       dh_installinfo
113         dh_installman
114         dh_link
115         dh_strip
116         dh_compress 
117         dh_fixperms
118 #       dh_perl
119 #       dh_python
120         dh_makeshlibs
121         dh_installdeb
122         dh_gencontrol
123         dh_md5sums
124         dh_builddeb
125 # Build architecture independant packages using the common target.
126 binary-indep: build-indep install-indep
127         $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
128
129 # Build architecture dependant packages using the common target.
130 binary-arch: build-arch install-arch
131         $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
132
133 binary: binary-arch #binary-indep
134 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch